You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
29 lines
748 B
Bash
29 lines
748 B
Bash
# Copyright 1999-2020 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=6
|
|
|
|
inherit multilib-build
|
|
|
|
DESCRIPTION="Meta-ebuild for clang runtime libraries"
|
|
HOMEPAGE="https://clang.llvm.org/"
|
|
SRC_URI=""
|
|
|
|
LICENSE="metapackage"
|
|
SLOT="${PV%_*}"
|
|
KEYWORDS="amd64 arm arm64 ppc64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
|
|
IUSE="+compiler-rt crt libcxx openmp +sanitize"
|
|
|
|
RDEPEND="
|
|
compiler-rt? (
|
|
~sys-libs/compiler-rt-${PV}:${SLOT}
|
|
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
|
|
)
|
|
crt? (
|
|
sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
|
|
)
|
|
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
|
|
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
|
|
|
|
REQUIRED_USE="sanitize? ( compiler-rt )"
|