forked from mirror/libcxx
You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
32 lines
834 B
C++
32 lines
834 B
C++
//===----------------------------------------------------------------------===//
|
|
//
|
|
// The LLVM Compiler Infrastructure
|
|
//
|
|
// This file is dual licensed under the MIT and the University of Illinois Open
|
|
// Source Licenses. See LICENSE.TXT for details.
|
|
//
|
|
//===----------------------------------------------------------------------===//
|
|
|
|
// <utility>
|
|
|
|
// template <class T1, class T2> struct pair
|
|
|
|
// template <class T1, class T2> void swap(pair<T1, T2>& x, pair<T1, T2>& y);
|
|
|
|
#include <utility>
|
|
#include <cassert>
|
|
|
|
int main()
|
|
{
|
|
{
|
|
typedef std::pair<int, short> P1;
|
|
P1 p1(3, static_cast<short>(4));
|
|
P1 p2(5, static_cast<short>(6));
|
|
swap(p1, p2);
|
|
assert(p1.first == 5);
|
|
assert(p1.second == 6);
|
|
assert(p2.first == 3);
|
|
assert(p2.second == 4);
|
|
}
|
|
}
|